Commit e6961e77 authored by Noah Prail's avatar Noah Prail

chore: Change FS to E1

parent 16ca51f1
Pipeline #9248 failed with stages
in 1 minute and 19 seconds
......@@ -27,7 +27,7 @@ package_deb:
stage: package
tags:
- docker
image: registry.filiosoft.com/docker/deb:latest
image: registry.e1dev.com/docker/deb:latest
dependencies:
- build
before_script:
......@@ -44,7 +44,7 @@ deploy_bin:
stage: deploy
tags:
- docker
image: registry.filiosoft.com/docker/aws-cli:latest
image: registry.e1dev.com/docker/aws-cli:latest
dependencies:
- build
- package_deb
......@@ -55,7 +55,7 @@ deploy_deb:
stage: deploy
tags:
- docker
image: registry.filiosoft.com/docker/deb:latest
image: registry.e1dev.com/docker/deb:latest
dependencies:
- build
- package_deb
......@@ -71,7 +71,7 @@ invalidations:
stage: post-deploy
tags:
- docker
image: registry.filiosoft.com/docker/aws-cli:latest
image: registry.e1dev.com/docker/aws-cli:latest
script:
- aws configure set preview.cloudfront true
- aws cloudfront create-invalidation --distribution-id E1MS659EX3VE05 --paths "/artificats/caddy/*"
......
......@@ -6,7 +6,7 @@ Bugs: https://github.com/mholt/caddy/issues
Vcs-Browser: https://github.com/mholt/caddy
Package: caddy
Version: VERSION
Maintainer: Filiosoft Developers <developers@filiosoft.com>
Maintainer: eventOne Developers <developers@event1.io>
Architecture: amd64
Copyright: debian/copyright
License: Apache
......
......@@ -2,8 +2,8 @@
# code modified from: https://github.com/abiosoft/caddy-docker/blob/master/builder/builder.sh
git config --global user.email "bot@filiosoft.com"
git config --global user.name "Filiosoft Commit Bot"
git config --global user.email "bot@event1.io"
git config --global user.name "eventOne Commit Bot"
VERSION=${VERSION:-"0.10.14"}
PLUGINS=$(cat plugins.txt)
......@@ -31,7 +31,7 @@ git clone https://github.com/caddyserver/builds $GOPATH/src/github.com/caddyserv
# build
cd $GOPATH/src/github.com/${CADDY_GITHUB}/caddy \
&& git checkout -f \
&& sed -i 's/unofficial/Filiosoft/g' caddymain/run.go \
&& sed -i 's/unofficial/eventOne/g' caddymain/run.go \
&& git add caddymain/run.go \
&& git commit -m "Version ${VERSION}" \
&& GOOS=linux GOARCH=amd64 go run build.go -goos=$GOOS -goarch=$GOARCH -goarm=$GOARM \
......
......@@ -34,12 +34,12 @@ cp bin/caddy_latest_amd64.deb bin/caddy_${VERSION}-${LATEST_PREFIX}-${CI_PIPELIN
wget -O - https://cdn.filiosoft.com/debian/pubkey.gpg | gpg --no-default-keyring --keyring trustedkeys.gpg --import
# setup repo mirror and pull
aptly mirror create filiosoft https://cdn.filiosoft.com/debian ${DISTRIBUTION}
aptly mirror update filiosoft
aptly mirror create e1 https://cdn.filiosoft.com/debian ${DISTRIBUTION}
aptly mirror update e1
# create new repo
aptly repo create -distribution=${DISTRIBUTION} -comment="${COMMENT}" -component=main caddy-release
# import mirror to repo
aptly repo import filiosoft caddy-release caddy
aptly repo import e1 caddy-release caddy
aptly repo add caddy-release bin/caddy_${VERSION}-${LATEST_PREFIX}-${CI_PIPELINE_ID}_amd64.deb
aptly snapshot create caddy-${VERSION} from repo caddy-release
......
#!/bin/bash
# Script to install the Filiosoft repo onto a
# Script to install the eventOne repo onto a
# Debian or Ubuntu system.
#
# Run as root or insert `sudo -E` before `bash`:
......@@ -76,10 +76,10 @@ exec_cmd() {
setup() {
print_status "Installing the Filiosoft repo..."
print_status "Installing the eventOne repo..."
if $(uname -m | grep -Eq ^armv6); then
print_status "You appear to be running on ARMv6 hardware. Unfortunately this is not currently supported by the Filiosoft Linux distributions."
print_status "You appear to be running on ARMv6 hardware. Unfortunately this is not currently supported by the eventOne Linux distributions."
exit 1
fi
......@@ -113,7 +113,7 @@ fi
IS_PRERELEASE=$(lsb_release -d | grep 'Ubuntu .*development' >& /dev/null; echo $?)
if [[ $IS_PRERELEASE -eq 0 ]]; then
print_status "Your distribution, identified as \"$(lsb_release -d -s)\", is a pre-release version of Ubuntu. Filiosoft does not maintain official support for Ubuntu versions until they are formally released."
print_status "Your distribution, identified as \"$(lsb_release -d -s)\", is a pre-release version of Ubuntu. eventOne does not maintain official support for Ubuntu versions until they are formally released."
exit 1
fi
......@@ -159,7 +159,7 @@ if [ "X${DISTRO}" == "Xdebian" ]; then
fi
fi
print_status 'Adding the Filiosoft signing key to your keyring...'
print_status 'Adding the eventOne signing key to your keyring...'
if [ -x /usr/bin/curl ]; then
exec_cmd 'curl -s https://cdn.filiosoft.com/debian/pubkey.gpg | apt-key add -'
......@@ -167,9 +167,9 @@ else
exec_cmd 'wget -qO- https://cdn.filiosoft.com/debian/pubkey.gpg | apt-key add -'
fi
print_status "Creating apt sources list file for the Filiosoft repo..."
print_status "Creating apt sources list file for the eventOne repo..."
exec_cmd "echo 'deb [arch=$(dpkg --print-architecture)] https://cdn.filiosoft.com/debian/ ${DIST} main' > /etc/apt/sources.list.d/filiosoft-${DIST}.list"
exec_cmd "echo 'deb [arch=$(dpkg --print-architecture)] https://cdn.filiosoft.com/debian/ ${DIST} main' > /etc/apt/sources.list.d/e1-${DIST}.list"
print_status 'Running `apt-get update` for you...'
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment